Collaborative Computational Project
for Electron cryo-Microscopy

MRC

Known CCP-EM issues

Installation on Ubuntu 19+ or Fedora 29+

The following error is seen trying to run CCP-EM on some recent Linux versions such as Ubuntu 19 and Fedora 29:

ImportError: .../libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

This can be fixed by running the following command:

rm $CCPEM/lib/libfreetype.so*

CCP4 can be affected by similar issues. If you still see such errors after trying the command above, run the command again but replace $CCPEM with $CCP4.

Installation on Mac OS X 10.15 Catalina

Some users report problems caused by the OS X Gatekeeper. This can cause a number of different errors including the following:

... cannot be opened because the developer cannot be verified. macOS cannot verify that this app is free from malware.

or:

ImportError: ... code signature in (...) not valid for use in process using Library Validation: library load disallowed by system policy

In some cases these problems can be fixed by running the following command:

xattr -rc $CCPEM

If that fails, please contact us. As a last resort, you could also consider disabling the Gatekeeper.